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AMENDMENT HISTORY 

Version Date Description 

V3.15 Dec, 2022 

1. Add New IC writer function 

TM52 series：TM52eF1375A. 

2. Modify some software/firmware bugs. 

3. Writer user manual update. 

V3.16 May, 2023 

1. Add New IC writer function : 

TM52 series：TM52eF1385 

TM56 series : TM56M1521H, TM56M1522, TM56F1542 

TM87series : TM87PL35L/ TM87PL35H 

2.        Modify some software/firmware bugs. 

3.        Writer user manual update. 

V3.17 Aug, 2023 

1. Add New IC writer function : 

TM52 series： TM52F1364 

2.        Modify some software/firmware bugs. 

3.        Writer user manual update. 

V3.18 Dec, 2023 

1. Add New IC writer function : 

TM52 series：TM52eF1375D, TM52F1376E, TM52F2384,  

TM52F1384 

TM56 series : TM56M152A, TM56M1522B, TM56M1522C 

TM87series : TM87P32 

2.        Modify some software/firmware bugs. 

3.        Writer user manual update. 

V3.19 Sep, 2024 

2. Add New IC writer function : 

TM52 series：TM52F5024, TM52F4974, TM52M5473  

TM56 series : TM56E6422 

TM87series : TM87P32 

2.        Modify some software/firmware bugs. 

3.        Writer user manual update. 

V3.20 Feb, 2025 

1. Add New IC writer function : 

TM52 series : TM52E5223, TM52F5864 

TM56 series : TM56F1552A, TM56F8152, TM56F6942, TM56F7052 

TM87 series : TM87PL39 

2.        Modify some software/firmware bugs. 

3.        Writer user manual update. 

V3.21 Sep, 2025 

1. Add New IC writer function : 

TM52 series : TM52F407A 

TM56 series : TM56F1521C, TM56F1543B, TM56F8022, TM56F8021,  

TM56F8022A, TM56E6421, TM56M7842 

TM57 series : TM57P75L1A, TM57P75D1A 

TM87 series : TM87PL35BH, TM87PL35BL 

2. Modify some software/firmware bugs. 

3. Writer user manual update. 

V3.22 Mar, 2026 

1. Add New IC writer function : 

TM52 series : TM52F6174 

TM54 series : TM54M0321, TM54M03C1 

TM56 series : TM56M7822, TM56F8222 

TM87 series : TM87PL39L, TM87PL39H 

2. Modify some software/firmware bugs. 

3. Writer user manual update. 
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PRODUCT NAME 

TWR98/99/100/100A 

 

TITLE 

USB Writer 

 

FEATURES 

1. USB Interface. 

2. The device can be attached to a computer and controlled by software for programming or it can also 

be operated independently as a stand-alone writer. 

3. Both software and firmware can be updated. 

 

1. Supported IC Series 

1.1 Supported IC Type 

1. 4-bit TM87 series:  

TM8793 TM8795 TM87P04 TM87P08 TM87ML23 

TM87ML28L TM87ML28H TM87P18M TM87ML22L TM87ML22H 

TM87ML25L TM87ML25H TM87ML26L TM87ML26H TM87PL37L 

TM87PL37H TM87PL36H TM87PL36L TM87PL35L TM87PL35L 

TM87P32 TM87PL39 TM87PL35BH  TM87PL35BL TM87PL39L 

TM87PL39H     
    Note1 : Only TWR100/100A hardware support 

 

2. 4-bit TM89 series:  

TM89P51M TM89P52M TM89P55M TM89P57M TM89P59M 

TM56F8406 TM52F8408    

 

3. 8-bit TM54 series: 

TM54M0321 TM54M03C1    

 

4. 8-bit TM55 series:  

TM55M8428 TM55M8228 TM55M8428T   

 

5. 8-bit TM56 series:  

 TM56F8225 TM56F8228 TM56F5412 TM56F5416 TM56F5412B 

TM56F5416B TM56F8406 TM52F8408 TM56P8440 M56F1522 

TM56F1552 TM56M1511 TM56M1531 TM56F1543 TM56M1521H 
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TM56M1522 TM56F1542 TM56M152A TM56M1522B, TM56M1522C 

TM56ME1522 TM56F1552A TM56F8152 TM56F6942 TM56F7052 

TM56E6422 TM56F1521C TM56F1543B TM56F8022 TM56F8021 

TM56F8022A TM56E6421 TM56M7842 TM56M7822 TM56F8222 

 

6. 8-bit TM57 series:  

 

TM57FA40 TM57FA40A TM57FLA80 TM57FLA80A TM57MA16 

TM57MA1660 TM57MA1668 TM57MA1672 TM57MA20 TM57MA51A 

TM57MA21B TM57MA25 TM57ME20 TM57ME16 TM57ME16AS 

TM57ML40 TM57MR10 TM57MR20 TM57PA10 TM57PA10A 

TM57PA11 TM57PA11B  TM57PA15 TM57PA16 TM57PA16AS 

TM57PA16B TM57PA20 TM57PA20A TM57PA20AS TM57PA20B 

TM57PA20E TM57PA21 TM57PA21B TM57PA25 TM57PA25B 

TM57PA28 TM57PA40 TM57PA40E TM57PA45 TM57PA45C 

TM57PE10 TM57PE11 TM57PE11A TM57PE11BS TM57PE11C 

TM57PE11CS TM57PE12 TM57PE12D TM57PE12AS TM57PE15AS 

TM57PE15A TM57PE15C TM57PE15CS M57PE20A TM57PE20B 

TM57PE40 TM57PT16 TM57PT16AS TM57PT16B TM57PT20A 

TM57PT20B TM57PT45 TM57PT45C TM57M5541 TM57M5545 

TM57M5551 TM57MA17 TM57MA18 TM57MA21BZ TM57MA28 

TM57ME15B TM57M5526C TM57M5536C TM57MA45 TM57MA46 

TM57M5406 TM57M5408 TM57M5610 TM57M5615 TM57ME15CG 

TM57M57M5640 TM57M5645 TM55M8228 TM57M8248 TM57M8248T 

TM57MA28B TM57MA28MB TM57MA29 TM57MA29C TM57M5620 

TM57M5625 TM57MA2835 TM57P8620 TM57P8625 TM57P8640 

TM57P8645 TM57M5625S TM57MA28NA TM57MA29NA TM57MA28ND 

TM57MA28NE TM57MA29ND TM57MA29NE TM57P75L1A TM57P75D1A 

           

7. 51 MCU series:      

 

TM52F2260 TM52F2261 TM52F2264 TM52F2280 TM52F2280B 

TM52F2284 TM52F2284B TM52M5254 TM52F5268B TM52F5274B 

TM52M5258 TM52F5264B TM52F5268 TM52F5288 TM52F5288C 

TM52F5278B TM52F5284 TM52F5284C TM52F5273B TM52F5274C 

TM52F5250 TM52F5264C TM52F5268C TM52F5273 TM52F2268 

TM52F5276B TM52F5278C TM52F5276 TM52M8268 TM52F8273 

TM52M8254 TM52M8258 TM52M8264 TM52F8273T TM52F8276T 

TM52F8276 TM52F8274 TM52F8278 TM52M8258B TM52M8264B 

TM52F8274T TM52F8278T TM52M8254B TM52FE8274 TM52FE8276 

TM52M8268B TM52F8368 TM52FE8278 TM52FE8976 TM52EF8278B 

TM52FE8273 TM52F8558 TM52F8658 TM52FE8276B TM52FE8273B. 

TM52FE8274B TM52F086A TM52F1376 TM52F0676 TM52F8368A 

TM52FC1335 TM52F1378 TM52F086B TM52FN8276 TM52FN8273 

TM52FN8274 TM52FN8278 TM52F0876 TM52F1732 TM52eF1374 

TM52eF1375  TM52F1375G TM52F1376B TM52F1363 TM52eF1375A 

TM52eF1385 TM52eF1386 TM52F1364 TM52eF1375D  TM52F1376E 



 

 

TWR98/99/100/100A Writer User Manual 

 
 

 

UM-TWR98_99_100_100A_E  6 Rev 3.22,  2026/03/03 

 

TM52F2384 TM52F1384 TM52F5024 TM52F4974,  TM52M5473 

TM52E5223,  TM52F5864 TM52F407A TM52F6174  

 

8. USB series:          

 

TMU3130 TMU3131 TMU3132 TMU3132LV TMU32FA80 

TMU3131F6 TMU3131F8    

 

 

1.2 Program Filename Extension: 

1. .epm file: TM87, TM89 series program filename 

2. .tenx file: 51 MCU series program filename 

3. .hex file: TM55, TM56, TM57 series program filename 
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2. Hardware and PC Setup 

2.1 System Requirements: 

a. Applicable in Windows 98/ME/2000/XP, Windows 7, Windows 8, Windows 8.1 system, 

Windows 10  system 

b. Need more than 100MB of hard disk space. 

 
2.2 PC Setup: 

a. The user to enter tenx company website : http://www.tenx.com.tw. 

b. Execute Setup_Writer_Version2.0.2_Build 024.exe to enter the installation program, follow the 

screen to complete the installation. 

  
2.3 Hardware connection: 

Step 1. Connect the DC 9V Adapter and USB Cable (mini B Type). 

 
 

Step 2. Turn the Power on. 

 
  

http://www.tenx.com.tw/
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3. Hardware Function Illustration 

a. TWR98  hardware (The following is a functional description) 

 
 

b. TWR99 hardware (The following is a functional description) 

 

 

3.3 

 

3.2 3.1 

3.5 

3.3 

3.2 3.1 

3.4 
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c. TWR100 hardware (The following is a functional description) 

 

d. TWR100A hardware (The following is a functional description) 

   

 Note : TWR100A hardware must be used with the writer board (as shown) 

                            TWR100A writer board, reserve a ground line for program with an automatic machine. 

 

3.3 

3.2 3.1 

3.4 

3.2 3.1 

3.3 

3.4 

3.5 
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3.1 Mode function Key: Select the program mode function: 

a. Mode1: CHIP NAME 

 
 

b. Mode2: AUTO (Blank check + Program+Verify) function 

 
 

c. Mode3: BLANKCHECK function 

(OTP series IC: Blankcheck) 

(FLASH/MTP series IC: Erase+Blank check) 

(Some models support EEPROM erase : TM52F1376, TM52F1378, TM52F1363, TM52F2384, 

 TM52F4974, TM52F5024, TM52E5223, TM52M5473, TM52F5864, TM52M59C4,  

TM56F1522, TM56F8152, TM56F1552A, TM56M1511, TM56M1531, TM56E6421,  

TM56E6422, TM56M152A, TM56F8021, TM56F8022 

 

 
 

d. Mode4: PROGRAM (Program+Verify) function 

 

 
e. Mode5: VERIFY function 
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f. Mode6: CHECKSUM_E =>Display the EEPROM buffer Checksum 

This function is used to check the correctness of the PC download data, which is to be 

programmed to the EEPROM. 

It is deemed correct if the Checksum value from EEPROM equals to the Checksum value 

from software. 

 
 

g. Mode7: CHECKSUM_O =>Display the OTP Chip Checksum 

This function is used to read back the data from the OTP Chip to do the Checksum 

calculation. 

It will be deemed correct only if the Checksum value from OTP chip equals to the 

Checksum value from EEPROM. 

 
 

h. Mode8: SW : =>Display Software version / FW : =>Display Firmware version 
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3.2 Enter function key: Execute the mode function 

 
3.3 LCD: Display the Mode function and programming result 

 
3.4 Programming Socket 

 

3.5 Writer IC programming-pins 

 
(TWR98/100機器)                        (TWR100機器)                        (TWR100A機器) 

 

Note 1: Program Port (picture left, mid and right P5 Port), Provide users with self-pull wire programming 

or programming on the board, P2 Port (picture right) only used in 4-bit programming. 

 

Note 2: When the TWR100 Writer user pulls wire form the Program Port (picture mid), VPP Pin need to 

add 100R ohm. 

 

3.5.1:  

TM87ML25L TM87ML25H TM87ML28L TM87ML28H TM87ML22L 

TM87ML22H TM87M23 TM87ML26L TM87ML26H TM87PL37L 

TM87PL37H TM87PL36H TM87PL36L TM87PL35H TM87PL35L 

TM87P32 TM87PL35BH TM87PL35BL   

              Program Pin : VL3, VBAT, RESET, GND, BAK, IOC3, IOC4. 

 
3.5.2:  

TM87P18M     

Program Pin : BAK, VBAT, VPP, GND, VDD3, RESET, INT. 

 
3.5.3:  

TM89P59 TM89P59M TM89P55M TM89P52M TM89P57M 
 

Program Pin : BAK, VBAT, VPP, RESET, GND, VL5, INT. 

 
3.5.4: 

TM8793 TM89P51M    

Program Pin : VL4 , VBAT, VPP, GND, BAK, RESET, INT. 

P2 P5 



 

 

TWR98/99/100/100A Writer User Manual 

 
 

 

UM-TWR98_99_100_100A_E  13 Rev 3.22,  2026/03/03 

 

3.5.5:  

TM87PL39L TM87PL39H    

Program Pin : VL4 , VBAT, GND, BAK, RFC0, CX 

 

3.5.6:  

TM57PA10 TM57PA40 TM57PE11 TM57PA20 TM57PA21 

TM57PE10 TM57PE11A TM57PA10A TM57PE12 TM57PE11B 

TM57PE15A TM57PE40 TM57PA21 TM57PA25 TM57PA20A 

TM57P11 TM57P11B TM57P11C TM57PE11C TM57PE15C 

TM57P11CU TM57PE12D TM57PA11 TM57PE20A TM57PT20A 

TM57PA45 TM57PA15 TM57PA21B TM57PA25B TM57PA16 

TM57PT16 TM57PT45 TM57MA25 TM57PA20B TM57PA28 

TM57PE20B TM57PT20B TM57PA16B TM57PT16B TM57PA45C 

TM57PT45C TM56P8440    

Program Pin : VPP, PA3, VDD, PA1, PA0, PA4, VSS. 

 

3.5.7:  

TM57PE11B TM57PE11C TM57PE15AS TM57PE15CS TM57PE15AS 

TM57PE12AS TM57PA20AS    

Program Pin : VPP, VDD, PA1, PA0, PA4, VSS. 

3.5.8:  

TM57P8620 TM57P8625 TM57P8640 TM57P8645 TM57P75D1 

TM57P75L1 TM57P75L1A TM57P75D1A   

             Program Pin : VPP , VBAT, PA0, PA1,PA3, PA4, VSS 

 
3.5.9:  

TM57FA40 TM57FA40A    

Program Pin : VPP, PA3, PA2, VCC, PA1, PA0, PA4,VSS. 

 

3.5.10:   

TM57FLA80 TM57ME20 TM57MR10 TM57MR20 TM57MR10 

TM57MA20 TM57MA21B TM57MA16 TM57MA1660 TM57MA1668 

TM57MA1672 TM57M5541 TM57M5545 TM57M5551 TM57MA17 

TM57MA18 TM57MA21BZ TM57MA28 TM57M5526C TM57M5536C 

TM57ME15B TM57ML40 TM57MA45 TM57MA46 TM57M5406 

TM57M5408 TM55M8228 TM55M5248 TM55M8248T TM57MA28B 

TM57MA28MB TM57MA29 TM57MA29C TM57MA28NA TM57MA29NA 

TM55M8428 TM55M8228 TM55M8428T TM57MA28NA TM57MA29NA 

TM55M8428 TM55M8228 TM55M8428T TM57MA28ND TM57MA28NE 

TM57MA29ND TM57MA29NE    

 

(1) non ISP mode 
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Program Pin : VPP, PA3, PA2, VDD5, PA1, PA0, PA4, PA6, VSS. 

 

(2) EXHV ISP mode  

Program Pin : VPP, VDD5, PA1, PA0, VSS. 

 

3.5.11:  

TM57ME16 TM57ME16AS    

Program Pin : VPP, PA3, VCC, PA1, PA0, VSS. 

 

3.5.12:  

TMU3130 TMU3132 TMU3132LV TMU32FA80  

(For the above 4 type, VDD5 and VDD need to be short-recorded when programming.) 

(1) non ISP mode 

Program Pin : VPP, PA3, PA2,VDD5, DP, DM, PA4, PA6, VSS. 

 
(2) EXHV ISP mode 

Program Pin : VPP, VDD5, DP, DM, VSS. 

 

3.5.13:  

TM52E5223     

 (1) non ISP mode 

Program Pin :VPP, VCC, P3.0, P3.1, P3.3, P3.4, VSS 

 

(2) EXHV ISP mode 

Program Pin :VCC, P3.0, P3.1, VSS 

 

3.5.14:  

TM52M5254 TM52M5258 TM52M8264 TM52M8268 TM52M8254B 

TM52M8258B TM52M8264B TM52M8268B TM52M5473  

 (1) non ISP mode 

Program Pin : VPP, P3.2, P3.3, VCC, P3.0, P3.1, P1.2, VSS. 

 

(2) EXHV ISP mode 

Program Pin : VPP, VCC, P3.0, P3.1, VSS. 

 

3.5.15:  

TM52F5276 TM52F5273 TM52F5274B TM52F5278B TM52F5264B 

TM52F5268B TM52F5250 TM52F5264C TM52F5268C TM52F5273B 

TM52F5274C TM52F5276B TM52F5278C   

 (1) non ISP mode 

Program Pin : VPP, P3.2, P3.3, VCC, P3.0, P3.1, P1.2, VSS. 

 

(2) EXHV ISP mode     

Program Pin : VPP, VCC, P3.0, P3.1, VSS. 

 



 

 

TWR98/99/100/100A Writer User Manual 

 
 

 

UM-TWR98_99_100_100A_E  15 Rev 3.22,  2026/03/03 

 

(3) ISP mode 

Program Pin : VCC, P3.0, P3.1, VSS 

3.5.16:  

TM52F5284 TM52F5288 TM52F5284C TM52F5288C  

(1) non ISP mode 

Program Pin : VPP, P1.1, P1.0, VCC, P1.2, P1.3, P4.3, VSS. 

 

(2) EXHV ISP mode 

Program Pin : VPP, VCC, P1.2, P1.3, VSS. 

 

(3) ISP mode 

Program Pin : VCC, P1.2, P1.3, VSS. 

 

3.5.17:  

TM52F2260 TM52F2261 TM52F2264   

 (1) non ISP mode 

Program Pin : VPP, P1.0, VBAT, P1.2, P1.3, VSS. 

 

(2) EXHV ISP mode 

Program Pin : VPP, VBAT, P1.2, P1.3, VSS. 

 

(3) ISP mode  

Program Pin : VBAT, P1.2, P1.3, VSS. 

 

3.5.18:  

TM52F2280 TM52F2284 TM52F2280B TM52F2284B TM52F2268 

 (1) non ISP mode                                                          

Program Pin : VPP, P1.1, P1.0, VCC, P1.2, P1.3, P0.7, VSS 

 

(2) EXHV ISP mode    

Program Pin : VPP, VCC, P1.2, P1.3, VSS. 

 

(3) ISP mode 

Program Pin : VCC , P1.2, P1.3, VSS. 

 

3.5.19:  
TM52F8273 TM52F8276 TM52F8274 TM52F8278 TM52F8273T 

TM52F8276T TM52F8274T TM52F8278T TM52F8368 TM52FE8278 

TM52FE8274 TM52FE8276 TM52FE8273 TM52F8558 TM52F8658 

TM52FE8976 TM52EF8278B TM52FE8274B TM52FE8276B TM52FE8273B 

TM52F086A TM52F1376 TM52F0676 TM52FC1335 TM52F1378 

TM52F086B TM52F8368A TM52FN8276 TM52FN8273 TM52FN8274 

TM52FN8278 TM52F0876 TM52F1732 TM52eF1374 TM52eF1375 

TM52F1375G TM52F1376B TM52F1363 TM52eF1375A TM52F1364 

TM52F1376E TM52FE1375D TM52F1384 TM52F5024 TM52F4974 
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TM52F407A TM52F6174    

 (1) non ISP mode 
Program Pin : P3.3, VCC, P3.0, P3.1, P1.2, VSS. 

 

(2) ISP mode  

Program Pin : VCC, P3.0, P3.1, VSS. 

 

3.5.20:  

TM52F2384     

 (1) non ISP mode                                                          

Program Pin:  VCC, P1.0, P1.2, P1.3, P0.7, VSS 

 

(2) ISP mode 

Program Pin:  VCC , P1.2, P1.3, VSS 

 

3.5.21:  

TM57M5640 TM57M5645 TM57M5620 TM57M5625 TM57M5625S 

TM56F8406 TM56F8408    

 (1) non ISP mode 

Program Pin : VPP, PA3, PA2, VBAT, PA1, PA0, VSS 

 

(2) EXHV ISP mode 

Program Pin : VPP, VBAT, PA1, PA0, VSS 

 

3.5.22:  

TM57M5610 TM57M5615    

           (These ICs are only for TWR100 hardware) 

(1) non ISP mode 
Program Pin : VPP, PA3, PA2, VBAT, CX, PA1, PA0, PA4, VSS. 

 

(2) EXHV ISP mode  

Program Pin : VPP, VBAT, CX, PA1, PA0, VSS. 

 

3.5.23:  

TM56F8225 TM56FE8228 TM56F5412 TM56F5416 TM56F5412B 

TM56F5416B TM56F1522 TM56F1552 TM56M1511 TM56M1531 

TM56F1543 TM56F1552A TM56F8152 TM56F7052 TM56F70C2 

TM56F1543B     

 (1) non ISP mode 

Program Pin : PA2, VCC, PA1, PA0, PA4, VSS.   

 

(2) ISP mode 

Program Pin : VCC, PA1, PA0, VSS. 
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3.5.24:  

TMU3131F6 TMU3131F8    

(For the above 2 type, VDD5 and VDD need to be short-recorded when programming.) 

(1) non ISP mode 

Program Pin : VPP , PA7, PA2,VDD5, DP, DM, PA4, VSS. 

 

(2) EXHV ISP mode 

Program Pin : VPP , VDD5, DP, DM, VSS. 

 

(2) ISP mode 

Program Pin : VSS, PA1, DP, DM. 

 

3.5.25:  

TM52eF1385 TM52eF1386    

(1) non ISP mode                                                          

Program Pin:  P3.3, VCC, P3.0, P3.1, P5.6, VSS 

(2) ISP mode 

Program Pin:  VCC , P3.0, P3.1, VSS 

 

3.5.26:  

TM56M1521H TM56M1522 TM56M1522B TM52M1522C TM56ME1522 

TM56M152A TM56E6422 TM56F1521C TM56F8022   TM56F8021 

TM56F8022A TM56E6421    

 (1) non ISP mode 

Program Pin:  VPP, VCC, PA0, PA1, PA4, PA5, VSS 

 

(2) EXHV ISP mode 

Program Pin:  VPP, VCC, PA0, PA1, VSS 

 

3.5.27:  

TM56F1542     

(1) non ISP mode 

Program Pin:  VCC, PA0, PA1, PA2, PD4, VSS 

 

(2) ISP mode 

Program Pin:  VCC, PA0, PA1, VSS 

 

3.5.28:  

TM56F6942     

(1) non ISP mode 

Program Pin:  VCC, PA0, PA1, PB0, PD4, VSS 

 

(2) ISP mode 

Program Pin:  VCC, PA0, PA1, VSS 

3.5.29:  
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TM56M7842 TM56M7822    

(1) non ISP mode 

Program Pin:  VPP, VCC, PA0, PA1, PB0, PA4, VSS 

 

(2) EXHV ISP mode 

Program Pin:  VCC, PA0, PA1, VSS 

 

3.5.30:  

TM54M0321 TM54M03C1    

(1) non ISP mode 

Program Pin:  VPP, VCC, PA0, PA1, VSS 

 

Note : If you follow the above process and still cannot burn effectively, it may be caused by the  

following reasons: 

1. The relationship between the programming line is too long or the wire is poor. 

2.  The instantaneous current demand of VDD/VCC is too large, causing the power 

supply of the writer to be shut down by the protection circuit. 

3. The capacitance of the programming pin power (VCC or VDD/or VBAT) should  

be less than 470uF. 

4. The capacitance of the programming pin (SDA/SCL) should be less than 100pF.  

5. The programming pin (SDA/SCL) should not be connected in series (current 

limit) or parallel (voltage division) resistors, which will affect the programming 

ability. 
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3.6 EX_Control: External Control Signal 

 

 

3.6.1: Signal Name and location 

9: N.C. 7: Result2 5: GND 3: Result0 1: VDD 

10: N.C. 8: N.C. 6: GND 4: Result1 2: Start 

 

3.6.2: Signal Function 

1. VDD =>Output Power, +3V 

2. Start signal =>Input Start signal, Low Pulse valid (start signal valid wide>50 ms)  

3. Result0, Result1 and Result2 pins =>Output Programming result, the status is as below: 

Result2 Result1 Result0 Status 

1 0 0 BUSY 

0 1 0 FAIL 

0 0 1 OK 
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3.7 Semi-automatic Machine Control Signals 

3.7.1: Program ok signal 

 
 

3.7.2: Program Fail signal 

 
 

3.8 LED Description: 

3.8.1: Yellow LED: the LED blinks when downloading writer file data or during writing process, 

means it is in busy state. 

3.8.2: Red LED: red light ON means writing process fails. When IC is taken away or writing mode 

is switched to another mode, LED will be switched off.  

3.8.3: Green LED: green light ON means the writing process succeeded. When IC is taken away or 

writing mode is switched to another mode, LED will be switched off. 
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4. Software Function Guide 

 
 

1. Display the programming data 

2. Display whether the Writer Device is connected to PC or not 

3. Display OTP IC programming-pins placement (Corresponding to the Hardware programming 

port) 

4. Display the file path of program 

5. Display the name of the programming CHIP 

6. Display IC program mode 

7. The functions of Auto, Blank check, Program, and Verify are the same as the hardware. When 

the USB Writer Device is connected to the PC, the programming commands can be directly 

programmed by the software 

8. Menu bar: 

8.1 File =>Load the programming file 

8.2 Device =>Select programming CHIP 

8.3 Operation =>Update firmware, Writer option set, Read IC information 

8.4 Help =>Writer Firmware Reset, Hareware Simple Test, Read Hardware ID 

8.5 About =>Display software version 

9. Checksum: Display the Checksum value of the programming file 

10. Smart Option: Display System Configuration definition 

  

2 

1 
3 

4 5 
6 

7 

8 

9 

10 
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5. Programming Software Operation 

Step 1: Start the writer software tool. 

 

Step 2: The writer is open; confirm that the writer Device is connected to PC 

 

Not connect 

Connect 



 

 

TWR98/99/100/100A Writer User Manual 

 
 

 

UM-TWR98_99_100_100A_E  23 Rev 3.22,  2026/03/03 

 

Step 3: Execute Device (Select CHIP)  Note: search function can be used to search 

 
 

Step 4: Select CHIP ok. 
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Step 5: Execute File =>Load File. 

 
 

Step 6: Load the file 
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Step 7: When loading the file, the hardware of the LCD will display as follows 

(Please don't power off or plug out USB cable) 

 
 

Step 8: Click on OK, download is completed 

(If you don't click the “OK” button, plug out USB cable will occur Writer stand lone 

operation error, please re-power the Writer can be restored to normal) 
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Step 9: Start execution (already  loading into hardware) 

 
 

Step 10: After successfully loading the file, the LCD panel on the hardware will display the CHIP 

NAME. 

 
 

Step 11: Select the function on the toolbar (Auto, Blank, Check, Program, Verify). 
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6. LCD Error Messages 

6.1:  PROTECT  => IC data are protected and cannot be read. 

6.2: BUSY FAIL => Check if the IC Programming signals are connected to Writer. 

6.3: B FAIL  => Blank Test fails 

6.4: P FAIL  => Programming data fails 

6.5: V FAIL  => Comparing data fails 

6.6: I FAIL  => Enter Programming Mode fails 

6.7: D FAIL  => Check ID fail 

6.8: F FAIL  => Programming FUSE or SYSTEM CONFIG fails 

6.9: NO CHIP => IC or connection is not connected properly. Please confirm whether IC is put 

properly or the line is connected perfectly. 

6.10: C/E FAIL => Writer Checksum data comparing error 

6.11: ENTRANCEF => Check IC entering write mode fail 

6.12: Busy Fail => Writer wait IC busy time out 

6.13: T(R)IRC Fail => Check IRC data error. 

6.14: VBG Fail => Check VBG data error. 

6.15: OTP Fail => Means that the IC only provides one-time programming. 

6.16: R Fail  => The program voltage is fail, please check the programming line/probe or    

                                         socket. 

6.17: EEPROM Fail => Writer EEPROM data check error 
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7. Set-up and Operations for Programming Serial Number 

Step 1: Select “Device” : 

 
 

Step 2: After selecting IC, please enable the “Display Serial Number”, and then click on “OK”. 
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Step 3: Enter “Serial Number Set” =>Set up the Serial Number parameters. 

 
 

Step 4:  Set up the S/N Length [Hex] (range: 0x01~0x10) 

Step 5:  Set up the S/N Start Address [Hex]. 

Step 6:  Set up the Start Serial NO [Hex]. 

Step 7:  Set up the S/N Amount [Hex] (the amount of OTP IC programming).  

Step 8:  Set up the S/N Direction [MSB In] 

For Example: Serial Number value=12345678 

Select “Low Byte” to program the IC location: 12 34 56 78 

Select “High Byte” to program the IC location: 78 56 34 12 

Step 9: After finishing set up, click the Load button (load the serial configuration data into Writer, 

please wait for it to complete) 

 
 

Step 10: After setting the “Serial Number Set” setup, click on the “Load” button. 

Step4 

Step5 

Step6 

Step7 

Step8

8 

Step9 
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Step 11: Execute File ->Load File 

 
 

Step 12: Wait until the files are downloaded OK, click on “ confirm ” button to enter the Serial 

Number Program mode 



 

 

TWR98/99/100/100A Writer User Manual 

 
 

 

UM-TWR98_99_100_100A_E  31 Rev 3.22,  2026/03/03 

 

 
 

Step 13: Click on “ S/N Program ” button to start programming  

 

Note: After the completion of programming, if programming code + serial number is desired, go back 

to Step 1 and start all over. 

After the above steps are completed, the user can choose two modes of operation: to connect to PC and 

let PC control the programming process or go offline and programmed by using writer independently. 
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1. Operating instruction in using PC to control the programming process: 

a. Click on S/N Program button to start the programming process. 

b. If programming is successful, the count number for “ Start Serial NO, OK, Total ” will be 

incremented by 1 automatically. 

c. If programming is fail, the count number for “ NG, Tota l ” will be incremented by 1 

automatically. 

d. When the S/N Program button is disabled, it means that the programming process for the serial 

number is completed. Reset and reload by entering the “ S/N SET ” window is required. 

e. “ Reset Count ” button will reset the “ OK, NG, Total ” column value to zero. 

f. Attention: Do not press the “ Enter ” key on the writer hardware during programming if PC 

control mode is used. 

 
2. Operating instruction in using writer for programming independently: 

a. The function for the Mode button is to choose whether to display the value for “ Serial Number, 

OK, NG, TOTAL ”. 

a-1: SNH =>Display Serial Number (9~16 bytes) , but when S/N Length is less than 9, this mode 

will not display the number. 

 
 

a-2: SNL =>Display Serial Number (1~8 bytes). 

 
 

a-3: OK =>Display the number of successful programming. 
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a-4: NG =>Display the number of fail programming. 

 
 

a-5: TOTAL =>Display the total number of programming. 

 
 

b. The function for the “ Enter ” key is to execute programming. 

c. If programming is successful, the value of “ Serial Number, OK, TOTAL ” will be incremented 

by 1 automatically. 

d. If programming is fail, the value of “ NG, TOTA L” will be incremented by 1 automatically. 

e. When the “ Enter ” key is disabled, it means that the programming for the serial number is 

completed and the must be reloaded. 

f. Attention: if the power of writer is turned off and on again, the serial number will be reset to the 

initial value. 
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8. Programming Operation in EXHV ISP Mode 

Step 1: Select Device 

 
 

Step 2: Select IC and enable “ EXHV ISP Program ”, and then click on “ OK ” 
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Step 3: The main screen will exhibit “ EXHV ISP Program ” 

 
 

Step 4: Select File ->Load File 
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Step 5：Wait until files are downloaded, click on OK to complete the download 

 
 

Step 6: Downloaded OK 

 
 

Note: The capacitance (VCC/VSS) on the PCB programming cannot exceed 470uF, and the 

capacitance (SDA/SCL) cannot exceed 100pF 
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9. Programming Operation in ISP Mode 

Step 1: Select Device  

 
 

Step 2: Select IC and enable “ ISP Program ”, and then click on “ OK ” 
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Step 3: The main screen will exhibit “ ISP Program ” 

 
 

Step 4: Select File ->Load File 
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Step 5: Wait until files are downloaded, click on OK to complete the download 

 
 

Step 6: Downloaded OK 

 
 

Note: The capacitance (VCC/VSS) on the PCB programming cannot exceed 470uF, and the 

capacitance (SDA/SCL) cannot exceed 100pF 
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10. Programming Operation in Whole Chip Erase Mode 

Step 1: Select Device  

 
 

 

Step 2: Select IC and enable “ Whole Chip Erase ”, and then click on “ OK ” 
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Step 3: The main screen will exhibit “Whole Chip Erase” 

 

 

Step 4: Select File ->Load File 
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Step 5: Wait until files are downloaded, click on OK to complete the download 

 

 

Step 6: Downloaded OK 
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11. Programming Guide for Mass Production Mode 

This function contains only Auto mode, which records OK and NG counts, and checksum display, there 

are no other functions, so it is recommended to be used in mass production. 

Step 1: Select Device 

 
 

Step 2: Select IC type and enable the “ Mass Production Mode ”, and then click on “ OK ” 
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Step 3: The main screen will show “ Mass Production Mode ” and Enable Auto function  

 
 

Step 4: Execute File ->Load File 
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Step 5: Wait until files are downloaded, click on OK to complete the download 

 
 

Step 6: Downloaded OK 
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Step 7: Hardware Display and Operate: 

a. Display CHIP NAME (Hold 2 sec Display) 

 
 

b. Display Auto Mode: (Mode button: click once will change OK and NG Display) 

1. Display Checksum 

2. Display the counting number that the programming procedure is successful 

3. Display the counting number that the programming procedure is not successful 

 
 

 
 

c. Display Software version and Firmware version (Press the Mode button more than 3 

seconds continuously to get the information) 

 
 

d. Enter button: press enter to execute 

  

Checksum 

OK數量 

NG數量 
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12. Production Limit Mode Writer Operation  

This function contains only Auto mode, which records OK and NG counts, and checksum display, there 

are no other functions, so it is recommended to be used in mass production. 

Step 1: Select Device  

 

 

Step 2: Select IC and enable the Production Limit Mode to set the writer counts (1~99999999) , then 

press OK. 
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Step 3: Main window will show “ Production Limit Mode ” and enable “ Auto ” function 

 
 

Step 4: Select File ->Load File 
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Step 5: Wait until files are downloaded, click on OK to complete the download 

 
 

Step 6: Download OK 
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Step 7: Hardware display and operation: 

a. Display CHIP NAME (holds for 2 secs display) 

 
 

b. Display Limit mode: (hardware mode button can only switch to OK and NG display) 

1. Checksum 

2. Write OK count 

3. Write NG count 

 
 

 
 

c. Display Software version and Firmware version (Press the Mode button more than 3 

seconds continuously to operate this function) 

 
 

d. Enter button: press enter to execute 

e. When OK count reaches the writing limit setting, writer will not continue to execute 

  

Checksum 

OK數量 

NG數量 
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13. Manually Update Firmware Function Guide 

Step 1: Execute Operation =>Update F/W 

 
 

Step 2: Select the file to Update. 
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Step 3: Start execution (start loading into hardware), click on OK to complete the set 

 
 

Step 4: During the Updating Firmware period, the LCD will display UPDATE_FW WAIT. 

 
 

Step 5: After successfully updating Firmware, the LCD will display the CHIP NAME. 
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14. Compare File Function Operation 

Display writer register data, “ IC Name ”, “ Download File Time ”, and “ Compare File Result ”. 

Step 1: Select Operation ->Compare File 

 

 

Step 2: Download File information window shows up 
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Step 3: Press “ Compare File ” button, select the file to be compared, then press “ Open ” button. 

 
 

Step 4: Wait for compare result, OK/Fail 
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15. Set Protect Function Operation 

Step 1: Select Operation ->Set Protect 

 
 

Step 2: Option Select 1 window shows up 
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Step 3: Select Unprotect or Protect, then press “ OK ” button, wait for the setting completes 
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16. Read Chip Info Function Operation 

Note: It does not support Mass Production and Production Limit mode. 

Read Target IC info, “ system config ”, “ checksum ”, “ ID ”. 

Step 1: Select Operation ->Read Chip Info 

 
 

Step 2: Read chip information window shows up 
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Step 3: Press “ Read ” button, start reading, wait for completed 
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17. Read Hardware ID Operation 

 
Step 1: Select Help -> Read Hardware ID 

 
 

Step 2: Click on OK, read writer hardware ID successfully 
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18. Read License ID Operation 

 
Step 1: Select Help -> Read License ID 

 

 
Step 2: Read Writer License ID successfully (details, please refer to License User Manual) 
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19. Reset Firmware Operation 

 
Step 1: Select Help -> Reset Writer F/W ->TWR98 or TWR99 

 

 
Step 2: Click on OK, reset firmware successfully 
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20. Writer Simple Test Operation 

 
Step 1: Select Help -> Writer Simple Test (Please remove the program port cable and chip first) 

            Or Writer Test function 

 

 

 
Step 2: Click on OK, writer simple test complete 
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21. Software Plugin Operation 

 
Step 1: Select Help -> Update Chip 

 

 
Step 2: Select plugin file.zip 
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Step 3: Click on OK, software update successfully 

 
 


